Hesitating when accelerating

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Post Reply

Topic author
mark40
Posts: 2
Joined: 07/06/11 22:05

Hesitating when accelerating

Post by mark40 » 20/10/19 9:55

Just taken the mr2 out today and on acceleration its hesitating and seems to misfire a bit. It’s been fine up to now but not
Driven it for about 4 months.
It doesn’t do it all the time it pulls good up hills and idles really well.
Some times it will accelerate through all the gears Like it should with no problems at all.
Read the ecu code and only shows one blink of the dashboard light then about five seconds pause then one blink again so
Don’t think there is any faults to display.
Anyone know where to start fault finding.



User avatar

jimi
Administrator
Administrator
Posts: 3723
Joined: 17/05/04 1:00
Gender: Male
Years of MR2 Ownership: 14
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Been thanked: 3 times
Contact:

Re: Hesitating when accelerating

Post by jimi » 21/10/19 5:37

Ecu code is normal for no stored faults. Fault codes are here https://www.mr2oc.co.uk/know-your-2/mk1 ... kbartid=61
If you haven't run it for 4 months then I'd suggest the following- clean (or replace) the spark plugs, check the HT leads are dry, clean and secure. Clean the contacts inside the distributor cap and the rotor arm. Put in fresh fuel.
Black is not a colour ! .... Its the absence of colour
Image


Topic author
mark40
Posts: 2
Joined: 07/06/11 22:05

Re: Hesitating when accelerating

Post by mark40 » 21/10/19 7:57

Ok thanks for the reply. Checked and cleaned plugs HT leads are fine.
Pulled the Distributor and found that two of the wires are near cut half way through so going to replace the cables.
Hopefully that might be the problem.

Post Reply

Return to “MK1”