'97 ABS / Power Steering issue

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Important ! - Please make your topic title as descriptive as possible . titles with just "help" generally dont get as many answers as a title that points to the problem
Post Reply

Topic author
DodgeRC
Posts: 4
Joined: 21/04/15 14:46

'97 ABS / Power Steering issue

Post by DodgeRC » 25/05/15 16:01

Hi all,

I was driving the other day, all was fine, had a good blast with the MR, the next day, had a drive and the ABS light was on, so got back, did some research and found Masons site about ABS faults etc.
Next day nipped to the gym and back, all was fine until I popped it into reverse on the drive, some reason my Power Steering light come on and was cutting in and out, had to keep the revs up as it sounded like it was going to cut out.

So I've tried to do the ABS fault check today however instead of getting any flashing code, I instead got no ABS light and the P/S light flashing constantly,

Any ideas?

Edit: With the the speedo has stopped working when the ABS light came on, and now the tachometer is jumpy, at idle it will jump to 1250, down to 1000, then back up, repeating.




Topic author
DodgeRC
Posts: 4
Joined: 21/04/15 14:46

Re: '97 ABS / Power Steering issue

Post by DodgeRC » 28/05/15 16:58

School boy error
7.5 ECU fuse...


Anniv152
Posts: 1
Joined: 15/06/19 8:45

Re: '97 ABS / Power Steering issue

Post by Anniv152 » 07/10/19 9:59

I wanted to say thank you for this post, it solved the same issue with my car. ABS light, Speedo not working, Engine Bay Fan not cutting in. These symptoms appeared while the car was in for a new exhaust. The garage were unable to resolve the issue and were scratching their head.
Just in case its not obvious, for me it was the ECU-IG 7.5A Fuse in the fuse box in the engine bay, I'm only pointing that out because there is another one in the frunk labelled ECU and this had no effect but was the first one i tried.

I have a 96 Rev 3 Anniversary Edition SW20

Post Reply

Return to “MK2”