Power steering problems

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Important ! - Please make your topic title as descriptive as possible . titles with just "help" generally dont get as many answers as a title that points to the problem
Post Reply

Topic author
Jebis
Posts: 2
Joined: 22/09/12 12:07

Power steering problems

Post by Jebis »

So i have 1995 japanese import rev 3 and it sounds like i'm having exactly the same problem and same symptoms as you.

The motor itself works when powered directly, the relay itself works when powered directly but when the relay is connected to the car its not closing the circuit. Also getting +12v from the battery to the relay on the other thick wire.

Anyone got any ideas what to try next, is it possible that the ecu or the control unit is bad?


User avatar

jimi
Administrator
Administrator
Posts: 4123
Joined: 17/05/04 1:00
Gender: Male
Years of MR2 Ownership: 16
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Been thanked: 16 times
Contact:

Re: Power steering problems

Post by jimi »

Split from this thread https://www.mr2oc.co.uk/forum/41/168260 ... 1#p1778451
:annoyed:
Please do not hijack other people's threads, apart from being very rude, it leads to confusion in the fault finding.
Black is not a colour ! .... Its the absence of colour
Image
User avatar

jimi
Administrator
Administrator
Posts: 4123
Joined: 17/05/04 1:00
Gender: Male
Years of MR2 Ownership: 16
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Been thanked: 16 times
Contact:

Re: Power steering problems

Post by jimi »

Have you got the relevent BGB ? If not then look here https://www.mr2oc.co.uk/download-cats/c ... 1-mk2.html
and here
https://www.mr2oc.co.uk/forum/198/80372.html
there's a whole section on power steering & fault diagnosis.
Black is not a colour ! .... Its the absence of colour
Image

Topic author
Jebis
Posts: 2
Joined: 22/09/12 12:07

Re: Power steering problems

Post by Jebis »

Okay sorry, my bad.

So. I've gone trough the bgb and found out that i'm missing the +5v from the ps ecu to control the relay. But if i disconnect the smaller plug on the relay then the ps ecu is sending the voltage.

So confusing. Maybe something wrong with the ecu itself and it can't handle the load in the relay?
Post Reply

Return to “MK2”