Rough idle after fueling

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Important ! - Please make your topic title as descriptive as possible . titles with just "help" generally dont get as many answers as a title that points to the problem
Post Reply

Topic author
CaseyJ
Posts: 6
Joined: 17/08/20 10:14

Rough idle after fueling

Post by CaseyJ »

Hi Guys,

I recently treated myself to an imported '95 Rev 3. When driving it home, the fuel cap seized on me and the fuel tank had only a slither of fuel. When I got home, I managed to pop the cap and fill her up a little with a jerry can. At this point, when the car starts, it starts for a few seconds and then the engine stalls with the engine management light showing. I then put some more fuel in and kept revving her to stop it from stalling. The car then sat idle without stalling but when revved over 4K RPM, it suddenly cuts the tachometer (indicating an electrical failure because of of how suddenly it dropped) and then the engine stalls.

Any thoughts on what the issue could be? I originally thought it was fuel related but the way the revs cut out indicate it could be electrical.

I should also mention that the car had been sitting (dry stored) for a while before I bought her.

Thanks,
Casey


User avatar

jimi
Administrator
Administrator
Posts: 4123
Joined: 17/05/04 1:00
Gender: Male
Years of MR2 Ownership: 16
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Been thanked: 16 times
Contact:

Re: Rough idle after fueling

Post by jimi »

Have you checked for stored error codes ? https://www.mr2oc.co.uk/know-your2/mk2/ ... codes.html
Black is not a colour ! .... Its the absence of colour
Image

MRHAPPY62
Full Member
Full Member
Posts: 1295
Joined: 19/02/12 15:27
Gender: Male
Years of MR2 Ownership: 8
MR2's Owned: 3
Real Name: JAMIE
Location: WEST SUSSEX
Has thanked: 3 times

Re: Rough idle after fueling

Post by MRHAPPY62 »

Have you replaced the fuel cap ?
I remember reading an old post that you must use a proper fuel cap .
MK2 3sge Uk sold.
MK3 Chilli red sold.
MK2 Smg Gltd Super Edition now with V6

Topic author
CaseyJ
Posts: 6
Joined: 17/08/20 10:14

Re: Rough idle after fueling

Post by CaseyJ »

jimi wrote: 17/08/20 12:05 Have you checked for stored error codes ? https://www.mr2oc.co.uk/know-your2/mk2/ ... codes.html
Not yet, I'll have another look when I have chance and check the codes.

MRHAPPY62 wrote: 17/08/20 18:18 Have you replaced the fuel cap ?
I remember reading an old post that you must use a proper fuel cap .
No, the fuel cap is stock. I don't think it was damaged when I unscrewed it.

MRHAPPY62
Full Member
Full Member
Posts: 1295
Joined: 19/02/12 15:27
Gender: Male
Years of MR2 Ownership: 8
MR2's Owned: 3
Real Name: JAMIE
Location: WEST SUSSEX
Has thanked: 3 times

Re: Rough idle after fueling

Post by MRHAPPY62 »

" I managed to pop the cap" was what made me think you had broken and replaced or not .
MK2 3sge Uk sold.
MK3 Chilli red sold.
MK2 Smg Gltd Super Edition now with V6

Topic author
CaseyJ
Posts: 6
Joined: 17/08/20 10:14

Re: Rough idle after fueling

Post by CaseyJ »

jimi wrote: 17/08/20 12:05 Have you checked for stored error codes ? https://www.mr2oc.co.uk/know-your2/mk2/ ... codes.html
Had a look at the error codes, I'm getting back 14 and 24, indicating it could be electrical. Has anyone had an issue like this before?
User avatar

peteV6R5
Posts: 2779
Joined: 13/08/07 13:06
Gender: Male
Years of MR2 Ownership: 12
MR2's Owned: 2
Real Name: Pete
Location: Stratford upon Avon
Has thanked: 2 times
Been thanked: 6 times

Re: Rough idle after fueling

Post by peteV6R5 »

https://www.google.com/search?rlz=1C1CH ... dnTHwPqSLM
those are igf ignighter or igniter lead to ecub(12) and air temp sensor MAF (24)
unless there was an issue before you brought it, cant see how these 2 would pop up just because you ran it very low on fuel.
I would reset the codes after filling with good quality (ie not old fuel). see if they reoccur.
if they do then start with downloading BGB in know your 2.
Image
Highland Drive 13/14/15/17/18/19
JAE 07/09/10/11/12/13/14/15/16/17
Japfest 09/11/12/13/16/19
Wales runs 14/15/16/17/18

Topic author
CaseyJ
Posts: 6
Joined: 17/08/20 10:14

Re: Rough idle after fueling

Post by CaseyJ »

peteV6R5 wrote: 21/08/20 14:08 https://www.google.com/search?rlz=1C1CH ... dnTHwPqSLM
those are igf ignighter or igniter lead to ecub(12) and air temp sensor MAF (24)
unless there was an issue before you brought it, cant see how these 2 would pop up just because you ran it very low on fuel.
I would reset the codes after filling with good quality (ie not old fuel). see if they reoccur.
if they do then start with downloading BGB in know your 2.
Thanks mate, I'll do that I see what happens.

Topic author
CaseyJ
Posts: 6
Joined: 17/08/20 10:14

Re: Rough idle after fueling

Post by CaseyJ »

I just put another £5 of fuel in her and she fired up first time with no warnings. Thanks for the help guys

Topic author
CaseyJ
Posts: 6
Joined: 17/08/20 10:14

Re: Rough idle after fueling

Post by CaseyJ »

Never mind, the issue came back today. The car stalls whilst idle but it's fine when revved high and the check engine light also disappears when revved. Would the IAT sensor cause this?
Post Reply

Return to “MK2”