Head Unit Help - Frankenstein's Monster...

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Important ! - Please make your topic title as descriptive as possible . titles with just "help" generally dont get as many answers as a title that points to the problem
User avatar

jeff
Administrator
Administrator
Posts: 1799
Joined: 28/04/03 1:00
Gender: Male
Years of MR2 Ownership: 19
MR2's Owned: 1
Real Name: Jeff
Location: Nottingham
Has thanked: 27 times
Been thanked: 5 times
Contact:

Re: Head Unit Help - Frankenstein's Monster...

Post by jeff »

benckj wrote: ↑17/08/21 9:43 My apologies, yes dual, unless you care to draw pistols at dawn.

Thank you for the correction.
sorry
bit of a pet peeve along with duel entry turbos, duel carriageways and duel fronted properties


Not Plan B again!! Why don't we just go with plan B in the first place?
It’s more important to lose a minute in life than your life in a minute

Topic author
50ShadesOfRed
Posts: 28
Joined: 19/07/20 13:37
Been thanked: 1 time

Re: Head Unit Help - Frankenstein's Monster...

Post by 50ShadesOfRed »

Thanks all!

Super fun times now however, as not shy of some overkill I decided to totally de-interior the car while chasing wires (easier....right.... πŸ€”). Upon closer inspection it appears that 6 out of the 8 speakers are totally knackered, so replacements have been bought too.

Looks like what was a "simple" head unit change has become a complete audio system overhaul - will update with how I get on...
User avatar

jeff
Administrator
Administrator
Posts: 1799
Joined: 28/04/03 1:00
Gender: Male
Years of MR2 Ownership: 19
MR2's Owned: 1
Real Name: Jeff
Location: Nottingham
Has thanked: 27 times
Been thanked: 5 times
Contact:

Re: Head Unit Help - Frankenstein's Monster...

Post by jeff »

if you have the time/inclination a writeup with pictures would be interesting addition to the knowledge base
Not Plan B again!! Why don't we just go with plan B in the first place?
It’s more important to lose a minute in life than your life in a minute
User avatar

jimi
Administrator
Administrator
Posts: 4746
Joined: 17/05/04 1:00
Answers: 1
Gender: Male
Years of MR2 Ownership: 17
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Has thanked: 9 times
Been thanked: 36 times
Contact:

Re: Head Unit Help - Frankenstein's Monster...

Post by jimi »

jeff wrote: ↑25/08/21 12:54 if you have the time/inclination a writeup with pictures would be interesting addition to the knowledge base
:th:
Definitely, even if you just put it all in a thread, I can convert it to a KY2 article ;)
Black is not a colour ! .... Its the absence of colour
Image
User avatar

benckj
Posts: 319
Joined: 05/04/06 1:00
Gender: Male
Years of MR2 Ownership: 5
Location: Alexandra, New Zealand
Been thanked: 3 times

Re: Head Unit Help - Frankenstein's Monster...

Post by benckj »

I’m not surprised your speakers are toast. They are very poor quality and seem to fall apart making them near useless. On my latest car a 98GT they dissengrated to dust leaving only rear magnet and inner cone.

Best purchase new speakers all around and fit into existing locations. It will take a little fabrication as often the new ones will be larger at 6-6.5”. Run new cables to each as OEM is very small and often damaged. Ditch the rear subs including amp and your life will be much easier. This will open up rear cubby holes for storing tools, t-top bags, fire extinguisher, etc.

Just my 0.02cents worth. There are write-ups in other Mr2 forums on how to do should you get stuck. It’s not complicated if your replacing all components.

Topic author
50ShadesOfRed
Posts: 28
Joined: 19/07/20 13:37
Been thanked: 1 time

Re: Head Unit Help - Frankenstein's Monster...

Post by 50ShadesOfRed »

Okie doke.
Me again!

So. I've had thr time to start removing the old wiring/ amp etc all sorts and that's now complete.

However I'm left with the following (I'm assuming) 2x stock wire groups with no plugs & three "loose" wires:

Pink with blue stripe
Black with red stripe
White with green stripe
IMG_20210911_181931.jpg
Brown with two dots
Red with two dots
Blue " "
Green " "
Yellow " "
Black " "
White " "
(+Random bare wire?)
IMG_20210911_181915.jpg
Green with one dot
Red with one dot
Black with one dot
White with one dot
(+Random bare wire)
IMG_20210911_181908.jpg
I can't seem to figure out what wires are the live/earth etc as they don't seem to match any guides I've seen - the guides all mention a "grey" wire, but unless I'm colourblind I can't see one ...

Any gurus feel like wading in?
Pretty please?
-awkward smile-
πŸ˜…
You do not have the required permissions to view the files attached to this post.
User avatar

jimi
Administrator
Administrator
Posts: 4746
Joined: 17/05/04 1:00
Answers: 1
Gender: Male
Years of MR2 Ownership: 17
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Has thanked: 9 times
Been thanked: 36 times
Contact:

Re: Head Unit Help - Frankenstein's Monster...

Post by jimi »

Never assume, assumption is the mother of all "censored" ;)

AFAIK, those 2 grey multi core wires (ie the coloured .wires with dots) are not standard.
The 3 loose wires could be standard IF they go into the main loom, can you see where they go ? Do the colours match up with the power antenna wiring on the standard diagrams ?
Black is not a colour ! .... Its the absence of colour
Image

Topic author
50ShadesOfRed
Posts: 28
Joined: 19/07/20 13:37
Been thanked: 1 time

Re: Head Unit Help - Frankenstein's Monster...

Post by 50ShadesOfRed »

Ok, I've dug around even more and the two grey wires go into the loom (I think?) And the others looks to be coming out of it also 😢😢😢

Stumped. Can't make head nor tail of it πŸ€”

This is what I've got...
Everywhere I look things seem to have the silver "dots" however?
(Other connectors etc)
IMG_20210912_154918.jpg
The grey wires also run down the length of the armrest/console etc, so are these 100% not supposed to be here?
You do not have the required permissions to view the files attached to this post.
User avatar

jimi
Administrator
Administrator
Posts: 4746
Joined: 17/05/04 1:00
Answers: 1
Gender: Male
Years of MR2 Ownership: 17
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Has thanked: 9 times
Been thanked: 36 times
Contact:

Re: Head Unit Help - Frankenstein's Monster...

Post by jimi »

The silver dots on the Toyota wiring don't mean anything or at least they are not part of the colour coding, only main colour/trace colour are relevant.
Those grey wires don't look standard to me if they are not wrapped as part of the loom then I'm fairly sure Mr T didn't put them there, should be relatively easy to trace them to the end.
Black is not a colour ! .... Its the absence of colour
Image

Topic author
50ShadesOfRed
Posts: 28
Joined: 19/07/20 13:37
Been thanked: 1 time

Re: Head Unit Help - Frankenstein's Monster...

Post by 50ShadesOfRed »

Oh I see πŸ€”
Ok, they were wrapped (sort of) with black tape but had been hacked into & spliced together pretty badly - there was a screw-type connector block and all sorts going on in there! I had to take it all off to see what was really going on.

I have been madly googling/searching and came across a thread on here where a member was reinstating his "active" system (which is what my 2 has/had).
The wiring colours seem to match up, but upon wiring in my ISO adapter....

... Nada 😢

(Dodgy connector block re-use to save me soldering/crimping needlesslyπŸ˜…)
IMG_20210912_170902.jpg
So now I'm (50%) more confident the colours at least match someone else's 2... It's troubleshooting time I guess.
Either that or I just wire things direct from the battery and bypass Mr T's loom completely and live without the radio antenna πŸ˜— (doing that for the amp + speakers anyway so... Food for thought)
You do not have the required permissions to view the files attached to this post.
User avatar

jimi
Administrator
Administrator
Posts: 4746
Joined: 17/05/04 1:00
Answers: 1
Gender: Male
Years of MR2 Ownership: 17
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Has thanked: 9 times
Been thanked: 36 times
Contact:

Re: Head Unit Help - Frankenstein's Monster...

Post by jimi »

Been looking through my files and came across these diagrams, which appear to correspond with what you have. Looks like the two grey cables are original :blush: you can see on the diagram they are shown as shielded (the bare wires are shielding) and the colours appear to match
1995-MR2-Wiring-Diagram 156.jpg
1995-MR2-Wiring-Diagram 157.jpg
The two grey cables should end up on the passengers side behind the trim panel under the rear quarter window (thats where the original amps were located)

Looks like the pink/blue & black/red wires are for the aerial. The white/green is an unknown at the moment, still looking to see if I can identify it. I can put a pdf copy of those pages in the downloads section if you want ?
You do not have the required permissions to view the files attached to this post.
Black is not a colour ! .... Its the absence of colour
Image
Post Reply

Return to β€œMK2”